SOFTELメモ

</> 技術者募集

【php】TLS1.2未満使用停止対応

問題

決済サービスは各種WebAPIで、TLS1.2未満使用停止の流れですが、phpから利用している場合、対応はどうしたらよいでしょうか。

答え

CentOSでyumでphpのものをインストールしている場合は、以下で対応可能。

# yum update nss curl

phpを、yumではなくて欲しいバージョンをソースからコンパイルしてインストールしているときは、nssやcurlを新しくしたら、再コンパイルすること。

file_get_contents や curl関数でTLS1.2未満使用停止のURLにもアクセスできるようになる。

php curl nss

関連するメモ

コメント