SOFTELメモ Developer's blog

会社概要 ブログ 調査依頼 社員募集 ...

composerをphpのバージョンに合わせる

問題

composer create-project --prefer-dist laravel/laravel myproject

compserでLaravelのプロジェクトを作ろうとしたのですが、以下のようなエラーがたくさん出ました。

  Problem 5
    - Installation request for laravel/framework v6.13.1 -> satisfiable by laravel/framework[v6.13.1].
    - laravel/framework v6.13.1 requires php ^7.2 -> your PHP version (5.6.40) does not satisfy that requirement.

この環境のphpは5.6.40なのですが、最新版を取得しようとしていて、バージョンが合わないと言っているのでしょうか。

答え

composerにphpのバージョンをお伝えしておくと、合わせてくれる。

composer config platform.php 5.6.40

その環境のphpが5.6.40ならば、globalに設定しておいてもよいでしょう。

composer global config platform.php 5.6.40

~/.config/composer/composer.json に以下が追記される。

{
    "require": {
        // 略
    },
    "config": {
        "platform": {
            "php": "5.6.40"
        }
    }
}

以後、指定したphpのバージョンに合わせてくれる。

関連するメモ

コメント