SOFTELメモ

</> 技術者募集

【debian】Firefox(Iceweasel)のなるべく新しいバージョンをインストールする

問題

debianでFirefoxを使いたいんだけど、Iceweaselをaptitudeしたらいいんですよね?

でもバージョンが古くて残念。。。

バージョンアップの管理などはパッケージ管理システムにお任せしたいので、aptitudeでFirefox(Iceweasel)の新しいのをインストールしたい。

答え

こちらを参照 → http://mozilla.debian.net/

OS: squeeze、使いたいのは: Iceweasel、欲しいバージョン:release など指定すると

/etc/apt/sources.list に以下を追記してね

deb http://backports.debian.org/debian-backports squeeze-backports main
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release

と教えてくれるので、そのとおりにする。

あとは、通常通りインストール。

aptitude update
aptitude install -t squeeze-backports iceweasel

最新っぽい aurora を試してみたところ、Firefox 8.0 相当になってしまいました。

普通でよい方は、releaseでよいと思います。

参考

Thunderbird(Icedove)も同じように新しいものをインストールできる。

関連するメモ

コメント(1)

shiremono 2011年10月1日 10:53

このとおりにやったらできました。ありがとうございます。
とくにauroraと指定しなければreleaseになるということでしょうかね。